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CLASS X - IT

SESSION 5: DOCUMENT TEMPLATE
1) What are Document Templates?
Templates or document templates refer to a sample fill-in-the-blank document that can help
in saving time. Usually templates are customized documents that may have sample content, themes,
etc. For example, if you want to create a resume you can use a resume template and modify only
the sections that require changes.
Creating a new document based on a template can save you time and effort because all the
work it takes to design the document has already been done. You may use the templates that come
with word processing software, or downloading templates created by other people, or you can also
create and save your own templates for future use. First of all, you need to create a document that
will serve as the template.
2) How to view sample templates available with your word processor ?
To view sample templates available with your word processor,
1) Go to File > New.
2) You will be displayed with different types of templates (Figure below). For example, if you would
like to create a letter, you can select the Letters option under Office.com Templates section.
Fill in the blanks:
1.

Templates or document templates refer to a sample fill-in-the-blank document.

2.

Creating a new document based on a template can save you time and effort because
all the work it takes to design the document has already been done.

EXERCISE
Perform the following activities till you are confident:
S.No. Activities
1.

Download and use templates from the internet

2.

You will now create a template of an invoice. An invoice is just the kind of document
that needs to have a set format and one that will be created over and over again.
Save the file with the name – {your name} _Invoice.

SESSION 6: WORKING WITH PAGE AND SECTION BREAKS
1) What are Page Breaks and Section Breaks?
Page and Section breaks can be used to separate a document into sections.
If you would like to start a new page in a document, you can use a page break.
To separate a section in a document, you can use the section break. For example, you can lay out
part of a single-column page as two columns.
To work with breaks, open a new document in the word processor and type some contents. if you need
another fresh page, choose the page break option in the Page Layout tab.
a)

Click on the Page Layout tab on the Ribbon.

b)

Click on the option Breaks in the Page Setup group (Figure below).

c)

A dropdown list with options for different types of breaks appears. An explanation is given for each
type of page or section break.

A page break can be inserted anywhere in a document to force the end of a page and the beginning of a new
one.
Section breaks add flexibility to formatting your document. Using them, you can create different headers
and footers, different footnote numbering, change the layout of columns, change page borders for different
pages, and even change page layouts in the same document! Using section breaks is like having minidocuments in one large document.
Fill in the blanks
1.

Page & Section breaks can be used to separate a document into sections.

2.

Using page breaks, you can create different headers and footers, different footnote numbering,
change the layout of columns, change page borders for different pages

3.

A section break controls the formatting of the document content that precedes
reaches another section break.

4.

To see a section/page break, click the Show/Hide button.

it, until it

Perform the following activities till you are confident:
S.No.

Activities

1.

Create Page and Section breaks

2.

Delete Page and Section breaks

3.

Open a new document. Divide your page into two columns. (Page Layout>Columns).
Pick up an article from a newspaper and key it in. try using column break and page
break anywhere in the text.

4.

Open a new document. type in the heading of your Local newspaper. Use section break
and divide the next section into columns and key in an article. Save the document file
as Newspaper_{your name} and print your document.

SESSION 7: APPLYING CHARACTER FORMATS
In order to apply formatting to the contents in the document you must select the concerned word or
group of words.
Fill in the blanks:
1.

After selecting the text you need to click the Grow Font icon in the Font group to make the font size
larger than the current font size.

2.
3.

To remove the character formatting, select the text and click on Clear Formatting Icon in the Font
group.
On selecting Sentence Case, the first character in the first word of the selected

4.

sentence will be converted to Capital Letter.
On selecting UPPERCASE, the first character in all the words of the selected
sentence will be converted to Capital Letter.

Perform the following activities till you are confident:
S.No.

Activities

1.

Change font face

2.

Change font size

3.

Change font color

4.

Highlight text

5.

Change text case

6.

Reopen the document created in the previous exercise Newspaper_{your name}.
Decorate the first page of your article using each one of the character formats you
have learnt in this exercise. take a printout of page 1 of the document and compare it
with the printout taken in the previous session.

SESSION 8: INSERT GRAPHICAL OBJECTS AND ILLUSTRATIONS
Most Word processors has support for inserting illustrations in the form of Clip Arts, Shapes, pictures,
charts, etc.
Clip Art can help in making a document look colourful and presentable. Clip arts are pre-defined images
available for use in documents.
To insert a clip art in a document,
1. Open a new document in word processor
2. Click on the insert tab on the Ribbon.
3. Click on the option Clip Art in the illustrations group
4. The Clip Art task Pane appears. Enter the clipart category name in the search box and Click
Go. For example, if you want to insert a logo, type logo in the search box and Click “Go”.
5. Once you click Go , a window appears along with list of clip arts matching the search keyword.
6. Select the clipart that you want to use, double-click on it and it will be inserted into your document.

1.

List any two websites that offers free clip arts.
Some of the websites that have free clip arts are:
• www.openclipart.org
• www.pdclipart.org
• www.clker.com
• www.freeclipartnow.com
• www.wpclipart.com

2.

What are Objects in a Word processing software?
Sounds, Music, drawings, documents spreadsheets, etc. are all examples of possible objects that you
can include in a document, or link to a document.. we can blend graphic images into our message, but
Word also allow us to blend in other special features. These features are generally known as “objects”.
These objects can be almost any form that can be generated as a computer file.

Fill in the blanks:
1. Embedding an object makes it part of the document while linking an object does not include the
object file into the document files.
2. Readers trying to access the linked object must also have direct access to the separate file that
forms that object.
3. Clip Art can help in making a document look colourful and presentable.
4. Clip Art is available under illustrations group in insert tab
Perform the following activities till you are confident:
S.No.

Activities

1.

insert pictures and Clip art in a document
Open a new document. Search for “Birthday Balloons” in Clip Art. Select one from
what is made available and make a one page birthday card for a family member
Download a few clip arts from the net and design a poster on Earth Day. in this exercise,
you will only insert the appropriate pictures. You will insert relevant text in the next
exercise.

2.
3.

SESSION 9: TEXT WRAPPING
1.

List any three word wrapping options available in a word processing software.
There are different Wrap text options such as In Line with text, Top and Bottom , Behind text , In front
of Text, Square, Tight, Through, etc.

Fill in the blanks:
1.

To search for a picture, place the cursor before the text, click insert tab, and click Picture under
illustrations.

2.

After you have inserted the picture, you can wrap the text by using the Wrap Text option under Text
section of the insert tab.

Perform the following activities till you are confident:
S.No.

Activities

1.

Wrap text around a picture

2.

Reopen the document you had created in Exercise 1, Gandhiji_{your Name}. Search
for an appropriate picture of Gandhiji and try all the text wrapping options. Select
the one you feel suits the best and take a printout of your modified article. Save your
document with a different name Gandhiji2_{your Name}.

SESSION 10: INSERTING OBJECTS
In addition to graphic images, to add a personal touch to a special message or to illustrate a special
feature, you may want to embed sound files or maybe even actual files from other software applications in
your document
To insert an object,
• Open a new word document
• Select Insert Tab
• Click Object under Text section. A dialog box will be displayed
• Select Create from File tab

• Click Browse and select a file such as a spread sheet or a PDF document that is available
on your computer, Click Open and Click OK
• Notice the document is available embedded within your word document.
Fill in the blanks:
1.

To open an embedded document, double-click on it.

2.

Embedded objects cannot be printed.

3.

When you embed objects in a document, you may have trouble emailing it because the size of your
document increases significantly.

Perform the following activities till you are confident:
S.No.
1.

Activities
insert objects in the text

SESSION 11: INSERT SHAPES, SYMBOLS AND SPECIAL CHARACTERS
You can insert objects that have different shapes such as lines, basic geometric shapes, arrows,
equation shapes, flowchart shapes, stars, banners, and callouts using the shape option.
To work with shapes, open a new document in word processor,
1.

Click on the Insert tab on the Ribbon.

2.

Click on the option Shapes in the Illustrations group

3.

Once you click the Shapes option a dropdown list with pre-defined shape such as box, circle,
etc. appears.

4.

You can select the shape from the list of shapes available and draw the shape by dragging the mouse
with the left button clicked. For example, if would like to insert a square, select the box shaped item
from the list, click and drag the shape to draw a square.

To work with symbols or special characters, open a new document in word processor.
1.

Click on the Insert tab on the Ribbon.

2.

Click on the option Symbol in the Symbols group

3.

A dropdown list appears

4.

Select a symbol from the list and double-click on to insert the symbol into the document.

Fill in the blanks:
1.

You can insert lines, basic geometric shapes, arrows, equation shapes, flowchart shapes,
stars, banners, and callouts using the shape option.

2.

Symbol option is available under Symbols group in the insert tab

Perform the following activities till you are confident:
S.No.

Activities

1.

Use different shapes, symbols and special characters in a document.

2.

Create a two page brochure for nainital or any other tourist spot near your town. the
brochure must include pictures. Wrap the text around the pictures. it must also include
a places to see, hotels to stay in and details of how to reach the place.
Open a new document. Create the basic flowchart diagram as shown below

3.

Unit 4: Spreadsheet (intermediate)
SESSION 1: USE AUTOSUM IN CELLS
Sum is one of the functions available in the spread sheet to perform addition of selected numbers in the
sheet. in this exercise, you will learn how to use autosum function to perform addition in a spread sheet.
Autosum is used for adding the values given in cells automatically without writing the formula to perform
the operation.
Autosum automatically selects the values around the cells either horizontally or vertically
Fill in the blanks:
1.

Automatic calculation of formulas is one of the most powerful features of electronic spreadsheets.

2.

Autosum is used for adding the values given in cells automatically without writing the formula.

3.

AutoSum option is available in Editing group under the Home tab.

4.

Autosum automatically selects the values around the cells either horizontally or
vertically.

Perform the following activities till you are confident:
S.No.
1.
2.
3.

Activities
Calculate without writing the formulae using the Autosum function
Create a list of all your personal expenses made during the month and calculate the
total expenses using the autosum function
Create a list of names of the month and holidays in that month. Add and calculate the
total number of holidays in a year using the autosum function

SESSION 2: CONDITIONAL FORMATTING
Conditional formatting allows you to change the formatting (font color, border, shading) of the cells based on
the values in it. Yes, you can do that manually, but it can be a tiresome task if you have a huge amount of
data. So, you specify a condition for the values in the cell, and if the condition is satisfied then automatically
the formatting of the cell changes.
This feature would be very useful if you were working on a profit and loss spreadsheet, or a temperature
variance spreadsheet, or a marksheet. You could highlight cells that have values are greater than a defined
rule with one color and those less than another with a different color.
1) List any five conditions/formats/items that can be used for conditional formatting.
Basically, you can select one or more cells, and create rules (conditions) for when and how those cells
are formatted. the conditions can be, based on the selected cell’s contents, or based on the contents
of another cell.
You can control the following formats:
• Number format
• Font, font style, and font colour (but not font size)

• Fill colour and fill pattern
• Border colour and border style (but not border thickness)
Fill in the blanks:
1.
2.

Conditional formatting allows you to change the formatting (font color, border, shading) of the cells
based on the values in it.
Conditional formatting is available under Styles group in Home tab.

Perform the following activities till you are confident:
S.No. Activities
1.

Perform conditional formatting on a data subset

2.

Create a student mark list of at least 10 students and five subjects. Highlight the marks
of the students who got marks greater than 80 with green colored text with blue fill. Save
the worksheet as Marks_{your name}.

SESSION 3: HIDE / UNHIDE / FREEZE ROWS AND COLUMNS
Sometimes you have data in rows and columns which are needed for formulas or charts, but you do not
want the data to be visible. A very handy feature of a spreadsheet is the ability to hide a row/column that
is not to be shown to the end user. the data in hidden row/column is available for calculations though not
visible!
Freezing rows and columns is another helpful feature in a spreadsheet. When you are dealing with a huge
amount of data that spans several rows or columns, you may want the headers to remain constant (frozen)
while you scroll through the data so that you can see the identifying names of the rows/columns.
To hide a row or column, do the following:
• In order to hide any row or column you can either select the particular row or column that is
to hidden or just one cell in the corresponding row or column.
• Click on Format option available under Cells group in the Home tab.
• A dropdown list appears
Click on Hide & Unhide > Hide Rows.
Note: Alternatively, you can select the row/column, right click and select Hide.
To freeze the rows or columns do the following.
• Open a new spread sheet.
• In order to freeze rows or columns click on Freeze Panes option available under Window
group in View tab.
• A drop down list appears as shown below. Click on Freeze Panes. Doing so will freeze all the rows
above and all the columns to the left of the selected cell. Scroll your mouse in the spreadsheet the
frozen rows and columns remain constant.
Fill in the blanks:
1.

When you freeze a row, Above row remains constant.

2.

Freeze Panes option is available under Window group in View tab.

3.

The panes are formed where your Cursor is placed.

Perform the following activities till you are confident:
S.No.

Activities

1.

Hide/unhide rows/columns

2.

Freeze/unfreeze rows/columns

3.

Create the worksheet given below, keeping your cursor on B2, try all the options of
freezing cells and observe the effect. Take specific note of column and row
movements. Save the worksheet as expenses_{your name}.

